summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:30 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:28:32 +0200
commitc8417d327ab52c53bc08391c72f0017bed2e83e8 (patch)
tree0a747c48590f33c64dd264f69ed8717ca2a2a41c /gnu/packages/xfce.scm
parent3372e5d1fcf6f9eac25f0f33ef1effb34e5d6133 (diff)
downloadguix-c8417d327ab52c53bc08391c72f0017bed2e83e8.tar.gz
gnu: Add xfce4-datetime-plugin.
* gnu/packages/xfce.scm (xfce4-datetime-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index afea4ccea2..bfd6542aa0 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1290,6 +1290,33 @@ core or CPU.")
 watch your every step.")
     (license gpl2+)))
 
+(define-public xfce4-datetime-plugin
+  (package
+   (name "xfce4-datetime-plugin")
+   (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-datetime-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-datetime-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1m7bmpvbmiz2xdffpg675qn80zx2n0cnlf842ppvh1q7zz18ndfd"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-datetime-plugin")
+    (synopsis "Display date and time inside the Xfce panel")
+    (description "This plugin shows the date and time in the panel,
+and a calendar appears when you left-click on it.")
+    (license gpl2+)))
+
 (define-public xfce4-embed-plugin
   (package
    (name "xfce4-embed-plugin")