summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-25 21:37:52 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-25 23:35:04 +0200
commitc09e331b25e35dc435af67765a9bdb2e8f4aa296 (patch)
treef37376eba5a7cbcbf23134fc64279043a31059ae /gnu/packages/xfce.scm
parent69afc5fd2351b2665fdfa7db5b14a70ac96925ba (diff)
downloadguix-c09e331b25e35dc435af67765a9bdb2e8f4aa296.tar.gz
gnu: xfce, mate: Propagate 'font-dejavu'.
Fixes <https://bugs.gnu.org/47713>.
Reported by bo0od <bo0od@riseup.net>.

This ensures applications such as IceCat can properly text (numbers in
the case of IceCat).

* gnu/packages/enlightenment.scm (enlightenment)[propagated-inputs]: Add
FONT-DEJAVU.
* gnu/packages/mate.scm (mate)[propagated-inputs]: New field.
* gnu/packages/xfce.scm (xfce)[propagated-inputs]: New field.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5782fa9eac..299e39115a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -37,6 +37,7 @@
   #:use-module (gnu packages base)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages cdrom)
+  #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
@@ -1011,6 +1012,9 @@ on your desktop.")
        ("xfce4-clipman-plugin"    ,xfce4-clipman-plugin)
        ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
        ("xfce4-xkb-plugin"        ,xfce4-xkb-plugin)))
+    (propagated-inputs
+     ;; Default font that applications such as IceCat require.
+     `(("font-dejavu"             ,font-dejavu)))
     (native-search-paths
      ;; For finding panel plugins.
      (package-native-search-paths xfce4-panel))