summary refs log tree commit diff
path: root/gnu/packages/xfig.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-11-24 14:22:16 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-11-24 18:28:52 +0100
commitfaef3b153acf450555fc640bd266a2e1321d9c99 (patch)
tree20ad3c38b83459cc354effec8d768ecf002952a5 /gnu/packages/xfig.scm
parentfa1e31b8a5c0d134020b8d4aa0c2d4ad0dca40da (diff)
downloadguix-faef3b153acf450555fc640bd266a2e1321d9c99.tar.gz
gnu: xfig: Add 'wrap-xfig phase.
* gnu/packages/xfig.scm (xfig): Set XAPPLRESDIR environment variable to help
  xfig find the app-defaults resource files.
Diffstat (limited to 'gnu/packages/xfig.scm')
-rw-r--r--gnu/packages/xfig.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/xfig.scm b/gnu/packages/xfig.scm
index b15407417f..6436e52ad6 100644
--- a/gnu/packages/xfig.scm
+++ b/gnu/packages/xfig.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -118,7 +119,14 @@
                   (close-pipe in)
                   (close-port out)))
               (zero? (system* "make" "install.doc"))))
-          %standard-phases)))))
+          (alist-cons-after
+           'install 'wrap-xfig
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/bin/xfig")
+                             `("XAPPLRESDIR" suffix
+                               (,(string-append out "/etc/X11/app-defaults"))))))
+           %standard-phases))))))
     (home-page "http://xfig.org/")
     (synopsis "Interactive drawing tool")
     (description