summary refs log tree commit diff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2021-02-07 11:28:21 +0100
committerLeo Famulari <leo@famulari.name>2021-02-09 15:06:08 -0500
commitd00380b0077b0df2a0b790bb115d07c1533b8863 (patch)
tree1dbca2ac6c426a5546af9e9e12710690c8f6fa13 /gnu/packages/xiph.scm
parent1e9f667708ba6fdc4b16fe6851bc0ea0b6306fad (diff)
downloadguix-d00380b0077b0df2a0b790bb115d07c1533b8863.tar.gz
gnu: vorbis-tools: Update to 1.4.2.
* gnu/packages/xiph.scm (vorbis-tools): Update to 1.4.2.
(source): Remove obsolete patches.
* gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch,
gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch,
gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 4a3f25e009..8ed0e518a7 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -312,18 +312,14 @@ Kate stream.")
 (define vorbis-tools
   (package
    (name "vorbis-tools")
-   (version "1.4.0")
+   (version "1.4.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "https://downloads.xiph.org/releases/vorbis/"
                                 "vorbis-tools-" version ".tar.gz"))
             (sha256
              (base32
-              "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))
-            (patches (search-patches 
-                       "vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch"
-                       "vorbis-tools-CVE-2014-9640.patch"
-                       "vorbis-tools-CVE-2015-6749.patch"))))
+              "1c7h4ivgfdyygz2hyh6nfibxlkz8kdk868a576qkkjgj5gn78xyv"))))
    (build-system gnu-build-system)
    (inputs `(("ao" ,ao)
              ("curl" ,curl)