summary refs log tree commit diff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-01-23 19:38:39 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-24 14:01:38 +0100
commita7f904fd6336b9acf8bc77c1ef3bb2483de2d2bd (patch)
tree5ed0cbf36c3c65a2117899771516c539ff0570ec /gnu/packages/xiph.scm
parent49e6291a7a257f89f01644423f1b685778b8862a (diff)
downloadguix-a7f904fd6336b9acf8bc77c1ef3bb2483de2d2bd.tar.gz
gnu: Add Opus 1.1.
* gnu/packages/xiph.scm (opus): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 6bd6658035..0e8cb5fafc 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,7 +41,8 @@
             ao
             flac
             libkate
-            vorbis-tools))
+            vorbis-tools
+            opus))
 
 (define libogg
   (package
@@ -278,3 +280,26 @@ ogginfo, to obtain information (tags, bitrate, length, etc.) about
          an ogg vorbis file.")
    (license license:gpl2)
    (home-page "http://xiph.org/vorbis/")))
+
+(define opus
+  (package
+    (name "opus")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.xiph.org/releases/opus/opus-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "158xprn2086arvdib3vbbygz7z6jqkw2nci7nlywzzwallap0wmr"))))
+    (build-system gnu-build-system)
+    (synopsis "highly versatile audio codec")
+    (description
+     "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
+is unmatched for interactive speech and music transmission over the Internet,
+but is also intended for storage and streaming applications. It is
+standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
+incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
+    (license license:bsd-3)
+    (home-page "http://www.opus-codec.org/")))