summary refs log tree commit diff
path: root/gnu/packages/xlockmore.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-12 21:15:15 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-12 23:33:08 +0100
commitab69d9ac864250153c1e9f4ef91622a5c3b7a9c3 (patch)
treeaa862c15b279bf394c1ef626406581476944ded7 /gnu/packages/xlockmore.scm
parentbb54c8ff051c767e30354e8a6eef5d256a2b2a94 (diff)
downloadguix-ab69d9ac864250153c1e9f4ef91622a5c3b7a9c3.tar.gz
gnu: Move xlockmore to (gnu packages xdisorg).
* gnu/packages/xlockmore.scm: Remove.
* gnu/packages/xdisorg.scm (xlockmore): New variable, from
  xlockmore.scm.
* gnu-system.am (GNU_SYSTEM_MODULES): Remove xlockmore.scm.
Diffstat (limited to 'gnu/packages/xlockmore.scm')
-rw-r--r--gnu/packages/xlockmore.scm56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnu/packages/xlockmore.scm b/gnu/packages/xlockmore.scm
deleted file mode 100644
index 75dad1a78c..0000000000
--- a/gnu/packages/xlockmore.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages xlockmore)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu)
-  #:use-module (guix licenses)
-  #:use-module (gnu packages xorg)
-  #:use-module (gnu packages linux))
-
-(define-public xlockmore
-  (package
-    (name "xlockmore")
-    (version "5.45")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
-                                 version "/xlockmore-" version ".tar.bz2"))
-             (sha256
-              (base32
-               "1xqm61bbfn5q056w57vp16gvai8nqpcw570ysxlm5h46nh6ai0bz"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:configure-flags (list (string-append "--enable-appdefaultdir="
-                                              (assoc-ref %outputs "out")
-                                              "/lib/X11/app-defaults"))
-       #:tests? #f))                            ;no such thing as a test suite
-    (inputs
-     `(("libX11" ,libx11)
-       ("libXext" ,libxext)
-       ("libXt" ,libxt)
-       ("linux-pam" ,linux-pam)))
-    (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
-    (synopsis "Screen locker for the X Window System")
-    (description
-     "XLockMore is a classic screen locker and screen saver for the
-X Window System.")
-    (license (bsd-style #f "See xlock.c.")
-             ;; + GPLv2 in modes/glx/biof.c.
-             )))