summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-09-12 13:26:51 -0400
committerLeo Famulari <leo@famulari.name>2016-09-13 20:37:33 -0400
commitb1a782b11aae2fa2bf8450c228638a0fd5cc9c83 (patch)
treef0cd5620ccb7a07eddb6a4d607b988869a6f1cf5 /gnu/packages/xml.scm
parent883d0a7d25b59f375b979b67f2a390c220ca53c8 (diff)
downloadguix-b1a782b11aae2fa2bf8450c228638a0fd5cc9c83.tar.gz
gnu: expat: Update to 2.2.0.
* gnu/packages/xml.scm (expat): Update to 2.2.0.
[source]: Use 'expat-CVE-2016-0718-fix-regression.patch'. Remove obsolete
patches.
* gnu/packages/patches/expat-CVE-2016-0718-fix-regression.patch: New file.
* gnu/packages/patches/expat-CVE-2012-6702-and-CVE-2016-5300.patch,
gnu/packages/patches/expat-CVE-2015-1283-refix.patch,
gnu/packages/patches/expat-CVE-2016-0718.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Add and remove patches.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index a478599fe6..bafbf42629 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -49,17 +49,16 @@
 (define-public expat
   (package
     (name "expat")
-    (version "2.1.1")
+    (version "2.2.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/expat/expat/"
                                  version "/expat-" version ".tar.bz2"))
-             (patches (search-patches "expat-CVE-2012-6702-and-CVE-2016-5300.patch"
-                                      "expat-CVE-2015-1283-refix.patch"
-                                      "expat-CVE-2016-0718.patch"))
+             (patches
+               (search-patches "expat-CVE-2016-0718-fix-regression.patch"))
              (sha256
               (base32
-               "0ryyjgvy7jq0qb7a9mhc1giy3bzn56aiwrs8dpydqngplbjq9xdg"))))
+               "1zq4lnwjlw8s9mmachwfvfjf2x3lk24jm41746ykhdcvs7r0zrfr"))))
     (build-system gnu-build-system)
     (home-page "http://www.libexpat.org/")
     (synopsis "Stream-oriented XML parser library written in C")