summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 14:53:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commit649e1676bc2369c43bae12b5c5dd74abe6234720 (patch)
tree0c15228838f2b4bf7483710794cda1b8498f3f60 /gnu/packages/xml.scm
parentdd686c0838c9685bc1307d74e61e8f2c3c5fc60a (diff)
downloadguix-649e1676bc2369c43bae12b5c5dd74abe6234720.tar.gz
gnu: Add XML::Compile::Tester.
* gnu/packages/xml.scm (perl-xml-compile-tester): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4e76cbc3c8..ecf079db4d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -374,6 +374,29 @@ from XML::Parser.  It parses XML strings or files and builds a data structure
 that conforms to the API of the Document Object Model.")
     (home-page "http://search.cpan.org/~tjmather/XML-DOM-1.44/lib/XML/DOM.pm")))
 
+(define-public perl-xml-compile-tester
+  (package
+    (name "perl-xml-compile-tester")
+    (version "0.90")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/"
+                                  "XML-Compile-Tester-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1bcl8x8cyacqv9yjp97aq9qq85sy8wv78kd8c16yd9yw3by4cpp1"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-log-report" ,perl-log-report)
+       ("perl-test-deep" ,perl-test-deep)))
+    (home-page "http://search.cpan.org/dist/XML-Compile-Tester")
+    (synopsis "XML::Compile related regression testing")
+    (description
+     "The @code{XML::Compile} module suite has extensive regression testing.
+This module provide functions which simplify writing tests for
+@code{XML::Compile} related distributions.")
+    (license (package-license perl))))
+
 (define-public pugixml
   (package
     (name "pugixml")