summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 14:53:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commitb494a5f1bd63fe302cd20a0af01c3ad93fa42b9f (patch)
tree9386008e327c9916a6c4fd0b0ba9dc62df315c86 /gnu/packages/xml.scm
parent649e1676bc2369c43bae12b5c5dd74abe6234720 (diff)
downloadguix-b494a5f1bd63fe302cd20a0af01c3ad93fa42b9f.tar.gz
gnu: Add XML::Compile.
* gnu/packages/xml.scm (perl-xml-compile): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ecf079db4d..78ce821883 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -397,6 +397,31 @@ This module provide functions which simplify writing tests for
 @code{XML::Compile} related distributions.")
     (license (package-license perl))))
 
+(define-public perl-xml-compile
+  (package
+    (name "perl-xml-compile")
+    (version "1.51")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/"
+                                  "XML-Compile-" version ".tar.gz"))
+              (sha256
+               (base32
+                "06fj4zf0yh4kf3kx4bhwrmrjr6al40nasasbgfhn8f1zxwkmm8f2"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-log-report" ,perl-log-report)
+       ("perl-xml-compile-tester" ,perl-xml-compile-tester)
+       ("perl-xml-libxml" ,perl-xml-libxml)
+       ("perl-test-deep" ,perl-test-deep)))
+    (home-page "http://search.cpan.org/dist/XML-Compile")
+    (synopsis "Compilation-based XML processing")
+    (description
+     "@code{XML::Compile} can be used to translate a Perl data-structure into
+XML or XML into a Perl data-structure, both directions under rigid control by
+a schema.")
+    (license (package-license perl))))
+
 (define-public pugixml
   (package
     (name "pugixml")