summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-13 21:06:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-13 22:49:16 +0200
commite436379c9412cf1550a6c977a5ede1aa4b8a1e04 (patch)
tree740ae991741f54734e578bb2a560f8d55b9ac8e2 /gnu/packages/xml.scm
parent24496210ea55bb1a573dcb80f4aa4bd13b861f1d (diff)
downloadguix-e436379c9412cf1550a6c977a5ede1aa4b8a1e04.tar.gz
gnu: expat: Replace with 2.2.9 [fixes CVE-2019-15903].
* gnu/packages/xml.scm (expat-2.2.9): New variable.
(expat)[replacement]: New field.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 54dc92f3f2..59f30116a3 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
@@ -67,6 +67,7 @@
   (package
     (name "expat")
     (version "2.2.7")
+    (replacement expat-2.2.9)
     (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
               (origin
                 (method url-fetch)
@@ -88,6 +89,23 @@ stream-oriented parser in which an application registers handlers for
 things the parser might find in the XML document (like start tags).")
     (license license:expat)))
 
+(define expat-2.2.9
+  (package
+    (inherit expat)
+    (version "2.2.9")
+    (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
+              (origin
+                (method url-fetch)
+                (uri (list (string-append "mirror://sourceforge/expat/expat/"
+                                          version "/expat-" version ".tar.xz")
+                           (string-append
+                            "https://github.com/libexpat/libexpat/releases/download/R_"
+                            (string-map dot->underscore version)
+                            "/expat-" version ".tar.xz")))
+                (sha256
+                 (base32
+                  "1960mmgbb4cm64n1p0nz3hrs1pw03hkrfcw8prmnn4622mdrd9hy")))))))
+
 (define-public libebml
   (package
     (name "libebml")