summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 20:19:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 20:36:34 +0100
commit55e1475cb58c1b9535b35f8bdb157b1435c54755 (patch)
treec9183e6b9425a66f084490514046f33fc402e42d /gnu/packages/xml.scm
parentb2205ae4f691c42573af19721fd1bd54f186fb58 (diff)
downloadguix-55e1475cb58c1b9535b35f8bdb157b1435c54755.tar.gz
gnu: python-lxml: Move to (gnu packages xml).
* gnu/packages/python-xyz.scm (python-lxml): Move from here ...
* gnu/packages/xml.scm (python-lxml): ... to here.
* gnu/packages/django.scm, gnu/packages/drones.scm,
gnu/packages/libreoffice.scm, gnu/packages/nutrition.scm,
gnu/packages/openstack.scm, gnu/packages/pulseaudio.scm,
gnu/packages/python-science.scm, gnu/packages/tryton.scm,
gnu/packages/wireservice.scm: Adjust module imports.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7259efb0f7..73ee26ed10 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2076,6 +2076,35 @@ For lxml.etree this package can be useful for providing XPath 2.0 selectors,
 because lxml.etree already has it's own implementation of XPath 1.0.")
     (license license:expat)))
 
+(define-public python-lxml
+  (package
+    (name "python-lxml")
+    (version "4.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "lxml" version))
+       (sha256
+        (base32 "01nvb5j8vs9nk4z5s3250b1m22b4d08kffa36if3g1mdygdrvxpg"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "make" "test"))))))
+    (inputs
+     `(("libxml2" ,libxml2)
+       ("libxslt" ,libxslt)))
+    (home-page "https://lxml.de/")
+    (synopsis "Python XML processing library")
+    (description
+     "The lxml XML toolkit is a Pythonic binding for the C libraries
+libxml2 and libxslt.")
+    (license license:bsd-3))) ; and a few more, see LICENSES.txt
+
+(define-public python2-lxml
+  (package-with-python2 python-lxml))
+
 (define-public python-xmltodict
   (package
     (name "python-xmltodict")