summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-27 04:43:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-27 04:49:19 +0200
commit3825b44448e1ba60b16b4169bdab391755297cfb (patch)
tree25d96f0591b8a5e8aab8c6dabd92bef9c3c3e1f4 /gnu/packages/xml.scm
parent4795e5e177e5aa7b79ce9d4b0965f81e058d594d (diff)
downloadguix-3825b44448e1ba60b16b4169bdab391755297cfb.tar.gz
gnu: xmlsec-nss: Fix tests (and hence build).
* gnu/packages/xml.scm (xmlsec-nss)[native-inputs]: Add nss:bin to
provide the certutil command.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4e4fa2da6c..9aa2800b9e 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -952,6 +952,10 @@ Libxml2).")
   (package
     (inherit xmlsec)
     (name "xmlsec-nss")
+    (native-inputs
+     ;; For tests.
+     `(("nss:bin" ,nss "bin")           ; for certutil
+       ,@(package-native-inputs xmlsec)))
     (inputs
      `(("nss" ,nss)
        ("libltdl" ,libltdl)))