summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-11-15 14:16:57 -0500
committerMark H Weaver <mhw@netris.org>2015-11-18 17:47:40 -0500
commitee6bb0cc763507b165674dbe03c6ae5d26c8da5c (patch)
tree34c4d1d29b5428f83113af81bc4464b432669c85 /gnu/packages/xml.scm
parent328a14e869c01ae4e33120a08a5d60c719263684 (diff)
downloadguix-ee6bb0cc763507b165674dbe03c6ae5d26c8da5c.tar.gz
gnu: libxml2: Add fixes for CVE-2015-{1819,7941,7942,8035} and other bugs.
* gnu/packages/patches/libxml2-CVE-2015-1819.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-8035.patch,
  gnu/packages/patches/libxml2-bug-737840.patch,
  gnu/packages/patches/libxml2-bug-738805.patch,
  gnu/packages/patches/libxml2-bug-746048.patch,
  gnu/packages/patches/libxml2-bug-747437.patch,
  gnu/packages/patches/libxml2-bug-751603.patch,
  gnu/packages/patches/libxml2-bug-751631.patch,
  gnu/packages/patches/libxml2-bug-754946.patch,
  gnu/packages/patches/libxml2-bug-754947.patch,
  gnu/packages/patches/libxml2-bug-755857.patch,
  gnu/packages/patches/libxml2-fix-catalog-corruption.patch,
  gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt1.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/xml.scm (libxml2)[source]: Add patches.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d9c92d6d93..90ad521c3d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -70,7 +70,28 @@ things the parser might find in the XML document (like start tags).")
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1g6mf03xcabmk5ing1lwqmasr803616gb2xhn7pll10x2l5w6y2i"))))
+               "1g6mf03xcabmk5ing1lwqmasr803616gb2xhn7pll10x2l5w6y2i"))
+             (patches
+              (map search-patch
+                   '("libxml2-fix-catalog-corruption.patch"
+                     "libxml2-bug-738805.patch"
+                     "libxml2-id-attrs-in-xmlSetTreeDoc.patch"
+                     "libxml2-CVE-2015-7941-pt1.patch"
+                     "libxml2-CVE-2015-7941-pt2.patch"
+                     "libxml2-node-sort-order-pt1.patch"
+                     "libxml2-bug-747437.patch"
+                     "libxml2-CVE-2015-1819.patch"
+                     "libxml2-bug-751603.patch"
+                     "libxml2-bug-751631.patch"
+                     "libxml2-node-sort-order-pt2.patch"
+                     "libxml2-bug-737840.patch"
+                     "libxml2-bug-754946.patch"
+                     "libxml2-bug-754947.patch"
+                     "libxml2-bug-755857.patch"
+                     "libxml2-CVE-2015-7942-pt1.patch"
+                     "libxml2-CVE-2015-7942-pt2.patch"
+                     "libxml2-bug-746048.patch"
+                     "libxml2-CVE-2015-8035.patch")))))
     (build-system gnu-build-system)
     (home-page "http://www.xmlsoft.org/")
     (synopsis "C parser for XML")