summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-13 15:56:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-13 15:56:53 +0100
commitee4e439acd74e377b9c12366d135c5eb8d389265 (patch)
tree435112ce2433f9a1fc2381220b951687b0c6f1c7 /gnu/packages/xml.scm
parent29fde3bffaa5cb314a901f4a2628353797e48c08 (diff)
downloadguix-ee4e439acd74e377b9c12366d135c5eb8d389265.tar.gz
gnu: minixml: Adjust to updated upstream tarball.
The release tarball was modified in place to add a top-level directory.

* gnu/packages/xml (minixml)[source]: Use non-tarbomb URL-FETCH.
[arguments]: Remove ‘fix-permissions’ phase.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d0216423e8..ba7c121776 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1017,28 +1017,18 @@ Libxml2).")
     (name "minixml")
     (version "2.12")
     (source (origin
-              (method url-fetch/tarbomb)
+              (method url-fetch)
               (uri (string-append "https://github.com/michaelrsweet/mxml/"
                                   "releases/download/v" version
                                   "/mxml-" version ".tar.gz"))
               (sha256
                (base32
-                "1z8nqxa4pqdic8wpixkkgg1m2pak9wjikjjxnk3j5i0d29dbgmmg"))))
+                "0kq3wiycb40dcyswvajrqb1n5ffm5xcnsfxxaml92vhpl6x57yvb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
        (list (string-append "LDFLAGS=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-permissions
-           ;; FIXME: url-fetch/tarbomb resets all permissions to 555/444.
-           (lambda _
-             (for-each
-              (lambda (file)
-                (chmod file #o644))
-              (find-files "doc" "\\."))
-             #t)))
        #:tests? #f))                    ; tests are run during build
     (home-page "https://michaelrsweet.github.io/mxml")
     (synopsis "Small XML parsing library")