summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 20:43:54 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-10 21:44:25 +0100
commit7fda7b8fad5ed47ef36d7d00d8e0652d6c43c268 (patch)
treea6f5f1518ea27aff798b09c7c4d748db4547b102 /gnu/packages/xml.scm
parente2bdf60982311a28f5643bebc4cc4cc47a2f9171 (diff)
downloadguix-7fda7b8fad5ed47ef36d7d00d8e0652d6c43c268.tar.gz
gnu: pugixml: Build as shared library.
* gnu/packages/patches/pugixml-versioned-libdir.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/xml.scm (pugixml)[source](patches): New field.
[arguments]: Instruct the build system to create a shared rather than static
library.
[native-inputs]: Add PKG-CONFIG.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c80dfb1eac..0ba23bcba4 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -861,14 +861,16 @@ the form of functions.")
       (method url-fetch)
       (uri (string-append "https://github.com/zeux/pugixml/releases/download/v"
                           version "/pugixml-" version ".tar.gz"))
+      (patches (search-patches "pugixml-versioned-libdir.patch"))
       (sha256
        (base32
         "19nv3zhik3djp4blc4vrjwrl8dfhzmal8b21sq7y907nhddx6mni"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags '("-DCMAKE_CXX_FLAGS=-shared -fPIC"
-                           "-DCMAKE_C_FLAGS=-shared -fPIC")
-       #:tests? #f))                    ; no tests
+     `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")
+       #:tests? #f))                     ;no tests
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (home-page "https://pugixml.org")
     (synopsis "Light-weight, simple and fast XML parser for C++ with XPath support")
     (description