summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-27 05:22:05 -0400
committerMark H Weaver <mhw@netris.org>2015-07-30 08:21:28 -0400
commit99e29da15690a696690b28b065e0d1b19c9610db (patch)
tree0e928d03ee131d93344a01bdc67a9a53060cf76d /gnu/packages/xml.scm
parent8c454dcd1254a2e16c4d01977859c62069137f5b (diff)
downloadguix-99e29da15690a696690b28b065e0d1b19c9610db.tar.gz
gnu: expat: Add fix for CVE-2015-1283.
* gnu/packages/patches/expat-CVE-2015-1283.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xml.scm (expat)[source]: Add patch.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 66d6d63a3f..2bce636f1c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -48,7 +49,8 @@
                                  version "/expat-" version ".tar.gz"))
              (sha256
               (base32
-               "11pblz61zyxh68s5pdcbhc30ha1b2vfjd83aiwfg4vc15x3hadw2"))))
+               "11pblz61zyxh68s5pdcbhc30ha1b2vfjd83aiwfg4vc15x3hadw2"))
+             (patches (list (search-patch "expat-CVE-2015-1283.patch")))))
     (build-system gnu-build-system)
     (home-page "http://www.libexpat.org/")
     (synopsis "Stream-oriented XML parser library written in C")