summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-20 17:19:00 +0100
commit901236474a9523595c0bdefd5ac22366e78b9e61 (patch)
tree667efe648d584b0c960b0da0d577b8a71b6b941c /gnu/packages/xml.scm
parent63d4ef52ebad4157817d56ccbe974da8fff81929 (diff)
parent64766d5cafd5cf19189ed274eb7e29ef784f90de (diff)
downloadguix-901236474a9523595c0bdefd5ac22366e78b9e61.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm36
1 files changed, 2 insertions, 34 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3a4cf01c7d..b25b06cf50 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -410,7 +410,7 @@ combination with @code{XML::Parser}, PerlSAX, @code{XML::DOM},
 (define-public perl-xml-libxml
   (package
     (name "perl-xml-libxml")
-    (version "2.0132")
+    (version "2.0134")
     (source
      (origin
        (method url-fetch)
@@ -418,7 +418,7 @@ combination with @code{XML::Parser}, PerlSAX, @code{XML::DOM},
                            "XML-LibXML-" version ".tar.gz"))
        (sha256
         (base32
-         "0xnl281hb590i287fxpl947f1s4zl9dnvc4ajvsqi89w23im453j"))))
+         "1ks69xymv6zkj7hvaymjvb78ch81abri7kg4zrwxhdfsqb8a9g7h"))))
     (build-system perl-build-system)
     (propagated-inputs
      `(("perl-xml-namespacesupport" ,perl-xml-namespacesupport)
@@ -1260,38 +1260,6 @@ files.  It is designed to be fast and to handle large input files.")
 (define-public python2-defusedxml
   (package-with-python2 python-defusedxml))
 
-(define-public libxls
-  (package
-    (name "libxls")
-    (version "1.4.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://sourceforge.net/projects/"
-                                  name "/files/" name "-"
-                                  version ".zip"))
-              (sha256
-               (base32
-                "1g8ds7wbhsa4hdcn77xc2c0l3vvz5bx2hx9ng9c9n7aii92ymfnk"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; Bootstrapping is required in order to fix the test driver script.
-         (replace 'bootstrap
-           (lambda _
-             (invoke "bash" "bootstrap"))))))
-    (native-inputs
-     `(("unzip" ,unzip)
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)))
-    (home-page "http://libxls.sourceforge.net/")
-    (synopsis "Read Excel files")
-    (description
-     "libxls is a C library which can read Excel (xls) files since Excel 97 (the BIFF8 format).
-libxls cannot write Excel files.")
-    (license license:bsd-2)))
-
 (define-public freexl
   (package
     (name "freexl")