summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-25 14:26:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 14:50:51 +0100
commit10cd39d1e03e267d0c47a80e7edf9f98a5ce8b5b (patch)
tree3748844b16655a0b38fdea49c34e7e31602967cf /gnu/packages/xorg.scm
parent404e48c4eda69dc308055dc7f317ee93ab6d6893 (diff)
downloadguix-10cd39d1e03e267d0c47a80e7edf9f98a5ce8b5b.tar.gz
gnu: xorg-server: Use 'modify-phases' syntax.
* gnu/packages/xorg.scm (xorg-server)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4c4af32a9c..ede07fa0ec 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5066,17 +5066,19 @@ over Xlib, including:
              "--enable-kdrive"
              "--enable-xephyr")
 
-       #:phases (alist-cons-before
-                 'configure 'pre-configure
-                 (lambda _
-                   (substitute* (find-files "." "\\.c$")
-                     (("/bin/sh") (which "sh")))
-
-                   ;; Don't try to 'mkdir /var'.
-                   (substitute* "hw/xfree86/Makefile.in"
-                     (("\\$\\(MKDIR_P\\).*logdir.*")
-                      "true\n")))
-                 %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'pre-configure
+          (lambda _
+            (substitute* (find-files "." "\\.c$")
+              (("/bin/sh") (which "sh")))
+
+            ;; Don't try to 'mkdir /var'.
+            (substitute* "hw/xfree86/Makefile.in"
+              (("\\$\\(MKDIR_P\\).*logdir.*")
+               "true\n"))
+            #t)))))
     (home-page "https://www.x.org/wiki/")
     (synopsis "Xorg implementation of the X Window System")
     (description