summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-05-13 09:22:44 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-05-16 14:23:17 +0200
commit5fdd142072def44b280dbf4ae02e05ad61b0629d (patch)
tree0eba6978419873c992dfc47516fd09cfce7f66a9 /gnu/packages/xorg.scm
parent0158ca7fdd6bc0d9d3b81e2017ee6c7a9c6fa483 (diff)
downloadguix-5fdd142072def44b280dbf4ae02e05ad61b0629d.tar.gz
gnu: Add the X color name database file.
* gnu/packages/xorg.scm (xorg-rgb): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fd933e36a7..2eff1b28c3 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4281,7 +4281,30 @@ Various information is displayed depending on which options are selected.")
 formatted dump file, such as produced by xwd.")
     (license license:x11)))
 
-
+(define-public xorg-rgb
+  (package
+    (name "xorg-rgb")
+    (version "1.0.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/app/rgb-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "1c76zcjs39ljil6f6jpx1x17c8fnvwazz7zvl3vbjfcrlmm7rjmv"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("xproto" ,xproto)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "X color name database")
+    (description
+     "This package provides the X color name database.")
+    (license license:x11)))
 
 ;; packages of height 1 in the propagated-inputs tree