summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-08-08 22:30:07 +0200
committerAndreas Enge <andreas@enge.fr>2014-08-08 22:30:07 +0200
commit43dd1cf360e911201d4d3bbfe5bb6fdbb418366e (patch)
treea32ae57e0463400244e2014e809205768e29f996 /gnu/packages/xorg.scm
parent4e3a820bfdf61cbc5be2ceb0ed8187f0066c6e97 (diff)
downloadguix-43dd1cf360e911201d4d3bbfe5bb6fdbb418366e.tar.gz
gnu: xorg: Add dri3proto.
* gnu/packages/xorg.scm (dri3proto): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 97b5ab2ff3..d6edefc6fc 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -331,6 +331,29 @@ tracking.")
     (license license:x11)))
 
 
+;; not part of X11R7.7, required for newer versions of mesa
+(define-public dri3proto
+  (package
+    (name "dri3proto")
+    (version "1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/proto/dri3proto-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "0x609xvnl8jky5m8jdklw4nymx3irkv32w99dfd8nl800bblkgh1"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "xorg implementation of the X Window System")
+    (description "X.org provides an implementation of the X Window System")
+    (license (license:x11-style "file://dri3proto.h"
+                                "See 'dri3proto.h' in the distribution."))))
+
+
 (define-public encodings
   (package
     (name "encodings")