summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-04 15:28:55 +0200
committerDavid Craven <david@craven.ch>2016-09-06 17:48:59 +0200
commitdfe05a514c192034fd65c7b5ca7e4d576b10ab4f (patch)
tree529a2f12d5022f4f0984cdf64df890a516ce88a5 /gnu/packages/xorg.scm
parent40b3f52399feeca34e20796c22776f6c462e42c0 (diff)
downloadguix-dfe05a514c192034fd65c7b5ca7e4d576b10ab4f.tar.gz
gnu: Add xorg-server-xwayland.
* gnu/packages/xorg.scm (xorg-server-xwayland): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fe14b1c6d4..0d3cdce37c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bison)
@@ -5155,6 +5157,23 @@ communicates with the user via graphical controls such as buttons and
 draggable titlebars and borders.")
     (license license:x11)))
 
+(define-public xorg-server-xwayland
+  (package
+    (inherit xorg-server)
+    (name "xorg-server-xwayland")
+    (inputs
+     `(("libepoxy" ,libepoxy)
+       ("wayland" ,wayland)
+       ,@(package-inputs xorg-server)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments xorg-server)
+       ((#:configure-flags flags)
+        `(cons* "--enable-xwayland" "--disable-xorg"
+                "--disable-docs"    "--disable-devel-docs"
+                "--disable-xvfb"    "--disable-xnest"
+                "--disable-xquartz" "--disable-xwin"
+                ,flags))))
+    (synopsis "Xorg server with wayland backend")))
 
 
 ;; packages of height 4 in the propagated-inputs tree