summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-14 12:42:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-15 20:31:24 +0100
commitfcb122b4ed3f8e7fde815a843338921e5d8302b0 (patch)
treeb895e7a05179f7d799d2e50f37ee8ee32b1a01d1 /gnu/packages/xorg.scm
parent20d090f43552e1e397a9eeb6ea2411976511b1cb (diff)
downloadguix-fcb122b4ed3f8e7fde815a843338921e5d8302b0.tar.gz
gnu: xterm: Fix uxterm in pure environments.
* gnu/packages/xorg.scm (xterm)[arguments]: Add a 'patch-file-names
phase.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 28ee64b96a..0aa4411ddc 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6087,7 +6087,19 @@ to answer a question.  Xmessage can also exit after a specified time.")
      '(#:configure-flags '("--enable-wide-chars" "--enable-load-vt-fonts"
                            "--enable-i18n" "--enable-doublechars"
                            "--enable-luit" "--enable-mini-luit")
-       #:tests? #f))
+       #:tests? #f                      ; no test suite
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'build 'patch-file-names
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* "uxterm"
+                 (("([ `\\|])(sh|sed|awk|xmessage) " _ prefix command)
+                  (string-append prefix (which command) " "))
+                 (("(`|\"|LANG=C )(locale) " _ prefix command)
+                  (string-append prefix (which command) " "))
+                 (("=xterm")
+                  (string-append "=" out "/bin/xterm")))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs