summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:57:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:57:35 +0200
commit65ba72d74954e85412144b4737fccfa914ff107b (patch)
tree3fdd314bb1584c46b1890f77ee407376a65000ea /gnu/packages/xorg.scm
parent839167ff9d74fc490b32f6a197591964f73b65e5 (diff)
downloadguix-65ba72d74954e85412144b4737fccfa914ff107b.tar.gz
gnu: libx11: Remove graft for 1.6.6.
* gnu/packages/xorg.scm (libx11): Update to 1.6.6.
[replacement]: Remove field.
(libx11-1.6.6): Remove variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3875765d25..787a508ab5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5238,8 +5238,7 @@ draggable titlebars and borders.")
 (define-public libx11
   (package
     (name "libx11")
-    (version "1.6.5")
-    (replacement libx11-1.6.6)
+    (version "1.6.6")
     (source
       (origin
         (method url-fetch)
@@ -5249,7 +5248,7 @@ draggable titlebars and borders.")
                ".tar.bz2"))
         (sha256
           (base32
-            "0pa3cfp6h9rl2vxmkph65250gfqyki0ccqyaan6bl9d25gdr0f2d"))))
+            "0ks1mxlda7nxfmffihi15ljsn50q8dknl33i2xag8xzc80fiizk5"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "doc"))                            ;8 MiB of man pages + XML
@@ -5269,20 +5268,6 @@ draggable titlebars and borders.")
     (description "Xorg Core X11 protocol client library.")
     (license license:x11)))
 
-;; Replacement package to fix multiple security bugs:
-;; <http://seclists.org/oss-sec/2018/q3/146>.
-(define-public libx11-1.6.6
-  (package
-    (inherit libx11)
-    (version "1.6.6")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://xorg/individual/lib/libX11-"
-                                  version ".tar.bz2"))
-              (sha256
-               (base32
-                "0ks1mxlda7nxfmffihi15ljsn50q8dknl33i2xag8xzc80fiizk5"))))))
-
 ;; packages of height 5 in the propagated-inputs tree
 
 (define-public libxcursor