summary refs log tree commit diff
path: root/gnu/packages/zip.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-20 19:27:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-09-28 00:20:30 +0200
commit8c120e4f3b5b18321a6545cbf60fa496f3774df3 (patch)
treec147b78d9221d3b67fd95093c2755b416aac5068 /gnu/packages/zip.scm
parent8be2428e852905b34212eefa65f7b086e08fba17 (diff)
downloadguix-8c120e4f3b5b18321a6545cbf60fa496f3774df3.tar.gz
gnu: zip: Use 'modify-phases'.
* gnu/packages/zip.scm (zip)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/zip.scm')
-rw-r--r--gnu/packages/zip.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/zip.scm b/gnu/packages/zip.scm
index 6defbda49e..c9fb70c031 100644
--- a/gnu/packages/zip.scm
+++ b/gnu/packages/zip.scm
@@ -48,11 +48,12 @@
                       (list "-f" "unix/Makefile"
                             (string-append "prefix=" out)
                             (string-append "MANDIR=" out "/share/man/man1")))
-       #:phases (alist-replace
-                 'build
-                 (lambda* (#:key (make-flags '()) #:allow-other-keys)
-                   (zero? (apply system* "make" "generic_gcc" make-flags)))
-                 (alist-delete 'configure %standard-phases))))
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'build
+                  (lambda* (#:key (make-flags '()) #:allow-other-keys)
+                    (zero? (apply system* "make" "generic_gcc" make-flags))))
+         (delete 'configure))))
     (home-page "http://www.info-zip.org/Zip.html")
     (synopsis "Compression and file packing utility")
     (description