summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:07 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commit134cafbd3f1ee792d41e0548027bafded72be89e (patch)
treee9467d5155d8c8430d2a15b334e375ef678088bf /gnu/packages
parent082431f5069482e00b66e97a805c727750f18e05 (diff)
downloadguix-134cafbd3f1ee792d41e0548027bafded72be89e.tar.gz
gnu: Add trytond-account-payment-sepa.
* gnu/packages/tryton.scm (trytond-account-payment-sepa): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7784a35f48..3b2e856e49 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -862,6 +862,32 @@ receivable/payable account to a clearing account defined on the payment
 journal.")
     (license license:gpl3+)))
 
+(define-public trytond-account-payment-sepa
+  (package
+    (name "trytond-account-payment-sepa")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_payment_sepa" version))
+       (sha256
+        (base32 "0clnl2lql5q0gh48lad3vw47xajgd3cdj4kbmvdi72jh775p174w"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_payment_sepa"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-stdnum" ,python-stdnum)
+       ("trytond" ,trytond)
+       ("trytond-account-payment" ,trytond-account-payment)
+       ("trytond-bank" ,trytond-bank)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-account-payment-sepa")
+    (synopsis "Tryton module for SEPA payment")
+    (description "The @emph{Account Payment SEPA} Tryton module allows to
+generate SEPA files for a Payment Group.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-product
   (package
     (name "trytond-account-product")