summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit1e2a8eabede47cd7853289595e710638c38cb64b (patch)
tree03e3c824268c6b65fabfdf38a71657ee204d8a22 /gnu/packages
parentd33cbcfdc8de76f4b84e0b13643a3a7dd174f17a (diff)
downloadguix-1e2a8eabede47cd7853289595e710638c38cb64b.tar.gz
gnu: Add trytond-analytic-invoice.
* gnu/packages/tryton.scm (trytond-analytic-invoice): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 497a7ad193..f950b9b844 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1311,6 +1311,31 @@ required to analyse accounting using multiple different axes.")
   (deprecated-package
    "python-trytond-analytic-account" trytond-analytic-account))
 
+(define-public trytond-analytic-invoice
+  (package
+    (name "trytond-analytic-invoice")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_invoice" version))
+       (sha256
+        (base32 "151vwcn5sgpqma9kjxbznx4v4wlhfc97dcyb432brxnswf5glcir"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "analytic_invoice"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-asset" ,trytond-account-asset)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-analytic-account" ,trytond-analytic-account)))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-invoice")
+    (synopsis "Tryton module to add analytic accounting on invoice")
+    (description "The @emph{Analytic Invoice} Tryton module allows to set
+analytic accounts on invoice line.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")