summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-02-17 18:30:00 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-18 14:14:39 +0100
commit569d7ba38c596ad092e5cd3b44922a6ba402da19 (patch)
treeca638fbae435e76bd20ff5f0207b2d06e319e729 /gnu/packages
parent33f2e862c7bf87e45d12dbd3e87501a64d5e69fe (diff)
downloadguix-569d7ba38c596ad092e5cd3b44922a6ba402da19.tar.gz
gnu: umockdev: Reference 'env' and 'sh' by absolute path.
* gnu/packages/check.scm
  (umockdev)[inputs]: Add 'bash-minimal' and 'coreutils-minimal'.
  (umockdev)[arguments]<#:phases>{absolute-filenames}: New phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8d422d4b85..68a0ac7a84 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -37,6 +37,7 @@
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2890,7 +2891,14 @@ provides a simple way to achieve this.")
                (add-after 'unpack 'fix-test
                  (lambda _
                    (substitute* "tests/test-umockdev.c"
-                     (("/run") "/tmp")))))))
+                     (("/run") "/tmp"))))
+               (add-after 'install 'absolute-filenames
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; 'patch-shebangs' will take care of the shebang.
+                   (substitute* (string-append #$output "/bin/umockdev-wrapper")
+                     (("env") (search-input-file inputs "bin/env"))
+                     (("libumockdev")
+                      (string-append #$output "/lib/libumockdev"))))))))
     (native-inputs
      (list vala
            gobject-introspection
@@ -2900,7 +2908,9 @@ provides a simple way to achieve this.")
            python
            which))
     (inputs
-     (list glib eudev libgudev))
+     (list bash-minimal ;for umockdev-wrapper
+           coreutils-minimal ;for bin/env
+           glib eudev libgudev))
     (home-page "https://github.com/martinpitt/umockdev/")
     (synopsis "Mock hardware devices for creating unit tests")
     (description "umockdev mocks hardware devices for creating integration