summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:19 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit8dd9ba3947b302392dfa47f20f45f64043993591 (patch)
tree55181ec77fdfb7c7b30981b9a2a2907c90a0292f /gnu/packages
parent8382a6d8bae23ee83ebcab6253076bcaf18ebcdf (diff)
downloadguix-8dd9ba3947b302392dfa47f20f45f64043993591.tar.gz
gnu: Add trytond-edocument-uncefact.
* gnu/packages/tryton.scm (trytond-edocument-uncefact): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index aea203cd8c..ed58ffb233 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1783,6 +1783,35 @@ duty based on the tariff code.")
 configure their dashboard.")
     (license license:gpl3+)))
 
+(define-public trytond-edocument-uncefact
+  (package
+    (name "trytond-edocument-uncefact")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_edocument_uncefact" version))
+       (sha256
+        (base32 "0b5qhkirfkrh5g1d7m42f7niiz86favf352i403fdi4j532sl3i2"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "edocument_uncefact"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("python-lxml" ,python-lxml)
+       ("trytond-account-invoice" ,trytond-account-invoice)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-edocument-unece" ,trytond-edocument-unece)))
+    (home-page "https://docs.tryton.org/projects/modules-edocument-uncefact")
+    (synopsis "Tryton module for electronic document UN/CEFACT")
+    (description "The @emph{Edocument UN/CEFACT} Tryton module implements
+electronic document from UN/CEFACT.  Supported formats are:
+
+@itemize
+@item Cross-Industry-Invoice (16B-CII)
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")