summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-29 02:53:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-29 02:56:47 +0100
commitb37ba3747a8949d8b46385ba963dba8b2c304b13 (patch)
tree405340bf5cf882b189b9c416da79f890122e9d8d /gnu/packages
parent1a6ca068275ffc69b5ba25ff7f1f829a01057681 (diff)
downloadguix-b37ba3747a8949d8b46385ba963dba8b2c304b13.tar.gz
gnu: bcachefs/static: Use G-expressions.
* gnu/packages/file-systems.scm (bcachefs/static)[arguments]:
Rewrite as G-expressions.
[inputs]: Remove labels.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/file-systems.scm36
1 files changed, 17 insertions, 19 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 7628f2c804..4bd55b40cd 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -515,27 +515,25 @@ performance and other characteristics.")
   (package
     (name "bcachefs-static")
     (version (package-version bcachefs-tools))
-    (build-system trivial-build-system)
     (source #f)
-    (inputs
-     `(("bcachefs-tools" ,bcachefs-tools/static)))
+    (build-system trivial-build-system)
     (arguments
-     `(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils)
-                      (ice-9 ftw)
-                      (srfi srfi-26))
-         (let* ((bcachefs-tools (assoc-ref %build-inputs "bcachefs-tools"))
-                (out (assoc-ref %outputs "out")))
-           (mkdir-p out)
-           (with-directory-excursion out
-             (install-file (string-append bcachefs-tools
-                                          "/sbin/bcachefs")
-                           "sbin")
-             (remove-store-references "sbin/bcachefs")
-             (invoke "sbin/bcachefs" "version") ; test suite
-             #t)))))
+     (list #:modules '((guix build utils))
+           #:builder
+           #~(begin
+               (use-modules (guix build utils)
+                            (ice-9 ftw)
+                            (srfi srfi-26))
+               (mkdir-p #$output)
+               (with-directory-excursion #$output
+                 (install-file (string-append #$(this-package-input
+                                                 "bcachefs-tools-static")
+                                              "/sbin/bcachefs")
+                               "sbin")
+                 (remove-store-references "sbin/bcachefs")
+                 (invoke "sbin/bcachefs" "version"))))) ; test suite
+    (inputs
+     (list bcachefs-tools/static))
     (home-page (package-home-page bcachefs-tools))
     (synopsis "Statically-linked bcachefs command from bcachefs-tools")
     (description "This package provides the statically-linked @command{bcachefs}