summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-05-16 22:57:39 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-24 17:19:03 +0200
commitbb03318a59560e0e7c8f66fa55b48cc030a787f7 (patch)
tree9debd661b138cc51f068851108a12adecb94feac /gnu/packages
parent1ffee0cf985399406ca79c3d14fe4b1c2fd85455 (diff)
downloadguix-bb03318a59560e0e7c8f66fa55b48cc030a787f7.tar.gz
gnu: python-tldr: Use g-exp.
* gnu/packages/python-xyz.scm (python-tldr)[arguments]: Rewrite with (guix gexp).

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ddb7e9b0bb..0148f482fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23995,16 +23995,16 @@ Public Suffix List's private domains as well.")
         (base32 "1hxmprqg8c4cvs19n7f80f3y7jj74i8sc2dmq2gdjmsdrb54bbzc"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'build 'build-doc
-           (lambda _
-             (invoke "make" "-C" "docs")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; This test fails. It tries to open a network socket.
-               (invoke "pytest" "-vv" "-k" "not test_error_message")))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'build 'build-doc
+                 (lambda _
+                   (invoke "make" "-C" "docs")))
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     ;; This test fails. It tries to open a network socket.
+                     (invoke "pytest" "-vv" "-k" "not test_error_message")))))))
     (native-inputs
      (list python-pytest python-pytest-runner python-sphinx-argparse))
     (inputs