summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-05 16:21:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 15:37:15 +0100
commit97b36ca4d3ab99190962a90da9627d559475dbd9 (patch)
tree937e44718ca63633207e095306aa72b0b5f4c4a9 /gnu/packages
parent6bb9424f22239a0a2f50133f8051c635bf9a409a (diff)
downloadguix-97b36ca4d3ab99190962a90da9627d559475dbd9.tar.gz
gnu: Add r-makecdfenv.
* gnu/packages/bioconductor.scm (r-makecdfenv): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c62c5970b8..1d1aae322c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6010,6 +6010,33 @@ reduction (between group analysis) and joint dimension reduction of two
 datasets (coinertia analysis).")
     (license license:artistic2.0)))
 
+(define-public r-makecdfenv
+  (package
+    (name "r-makecdfenv")
+    (version "1.74.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "makecdfenv" version))
+              (sha256
+               (base32
+                "0bvj5dg6yfjnhga1z8788zmb98d8shyz8pzz0ggnml87c1p2gy25"))))
+    (properties `((upstream-name . "makecdfenv")))
+    (build-system r-build-system)
+    (inputs (list zlib))
+    (propagated-inputs
+     (list r-affy
+           r-affyio
+           r-biobase
+           r-zlibbioc))
+    (home-page "https://bioconductor.org/packages/makecdfenv")
+    (synopsis "Chip description file environment maker")
+    (description
+     "This package implements two functions.  One of them reads an Affymetrix
+@acronym{CDF, chip description file} and creates a hash table environment
+containing the location/probe set membership mapping.  The other one creates a
+package that automatically loads that environment.")
+    (license license:gpl2+)))
+
 (define-public r-metaneighbor
   (package
     (name "r-metaneighbor")