summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-06 06:14:53 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-09 09:25:09 +0200
commitb9e0aff9dcd727ddf106592dc92f3f9b0fb5eedf (patch)
tree017ad32c9939246721fe16443436fc282ec9699d /gnu/packages
parentef5636c35c352e66eea19a87caed228173cad46d (diff)
downloadguix-b9e0aff9dcd727ddf106592dc92f3f9b0fb5eedf.tar.gz
gnu: Add emacs-telephone-line.
* gnu/packages/emacs-xyz.scm (emacs-telephone-line): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f55ef048f7..483f0cdd9d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -522,6 +522,31 @@ repositories through the
 server}.  The main advantage compared to @code{vc-hg} is speed.")
     (license license:gpl3+)))
 
+(define-public emacs-telephone-line
+  (let ((commit "6f3455a365912e8f0c45a2240ea79507dee45ade")
+        (revision "0"))
+    (package
+      (name "emacs-telephone-line")
+      (version (git-version "0.5" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/dbordak/telephone-line")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1hnd6wnc52sc0ckriqnhaz64pyjk027y0dpcmh2zhpd27i8d4hmq"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/dbordak/telephone-line")
+      (synopsis "Implementation of Powerline for Emacs")
+      (description
+       "Telephone Line is a new implementation of Powerline for Emacs with
+optional baked-in Evil support, antialiased separators, and an easy
+configuration language which makes it trivial to write your own themes.")
+      (license license:gpl3+))))
+
 (define-public emacs-terminal-here
   (package
     (name "emacs-terminal-here")