summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-04 22:56:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-04 23:10:21 +0100
commitf3d4015385bdfc652ff1fe024254fd5e73c6fca8 (patch)
treef485e79a49837c23e85217e43002f651af7a0668 /gnu/packages
parent6b84a31d905653d6493b5130e8230df0456ae6ba (diff)
downloadguix-f3d4015385bdfc652ff1fe024254fd5e73c6fca8.tar.gz
gnu: girara: Fetch sources from git.
The tarball URI is having server issues.  Use the upstream git
repository instead until this is resolved.

Reported by Marius Bakke <mbakke@fastmail.com>.

* gnu/packages/gtk.scm (girara)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 379e09d9f5..777601ed97 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1377,14 +1377,15 @@ and routines to assist in editing internationalized text.")
   (package
     (name "girara")
     (version "0.3.3")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/girara/download/girara-"
-                              version ".tar.gz"))
-              (sha256
-               (base32
-                "13vr62kkkqs2xsrmsn114n6c6084ix1qyjksczqsc3s2y3bdsmj4"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.pwmt.org/pwmt/girara")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0q0yfv2777s72p473lw0ll435n7vz4v204cmp9naq8am7a6i6avn"))))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)
                      ("gettext" ,gettext-minimal)