summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:39:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:10 +0200
commit0050d124fd3df1fcd270fc839931c818a8e1fd7f (patch)
treec7d394545f883562b0304e22886393e775773501 /gnu/packages
parent9c2a372b3990fb9c1fb0eff4d562f37808e462b1 (diff)
downloadguix-0050d124fd3df1fcd270fc839931c818a8e1fd7f.tar.gz
gnu: Add texlive-physconst.
* gnu/packages/tex.scm (texlive-physconst): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a1947581b5..233195037f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5399,6 +5399,33 @@ number of units provided should cover--in Turton's estimate--about 90 percent
 of all fluid processing operations.")
     (license license:lppl1.3c)))
 
+(define-public texlive-physconst
+  (package
+    (name "texlive-physconst")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/physconst/"
+                   "source/latex/physconst/"
+                   "tex/latex/physconst/")
+             (base32
+              "1jrhsycm9fp4crhy4g9i4hn7wll85fczwmvxvlzgkzi249zcssm9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/physconst")
+    (synopsis "Macros for commonly used physical constants")
+    (description
+     "This package consists of several macros that are shorthand for a variety
+of physical constants, e.g. the speed of light.  The constants can be used in
+two forms, the most accurate available values, or versions that are rounded to
+3 significant digits for use in typical classroom settings, homework
+assignments, etc.  Most constants are taken from CODATA 2018, with the
+exception of the astronomical objects, whose values are taken from
+International Astronomical Union specified values.  Constants that are derived
+from true constants, e.g. the fine structure constant, have been calculated
+using the accepted values of the fundamental constants.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")