summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:02:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit037194373a9ebfab3829963b84854ece2f9fdc50 (patch)
tree367c0786b68740e84f276d1265eb5099a3b559b2 /gnu/packages
parent818d99abe2f78a4683b105c570eb3d91c04e366f (diff)
downloadguix-037194373a9ebfab3829963b84854ece2f9fdc50.tar.gz
gnu: Add go-github-com-modern-go-concurrent.
* gnu/packages/golang.scm (go-github-com-modern-go-concurrent): New
variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: Ie42473a28271069abea34b175dc2d98aeb6e66b9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0bcc84e0e6..50a8eab39c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1845,6 +1845,30 @@ Domain Name Service}.  The API follows the less-is-more principle, by
 presenting a small interface.")
     (license license:bsd-3)))
 
+(define-public go-github-com-modern-go-concurrent
+  (package
+    (name "go-github-com-modern-go-concurrent")
+    (version "1.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/modern-go/concurrent")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s0fxccsyb8icjmiym5k7prcqx36hvgdwl588y0491gi18k5i4zs"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/modern-go/concurrent"))
+    (home-page "https://github.com/modern-go/concurrent")
+    (synopsis "Concurrency utilities for Go")
+    (description
+     "A Go library providing various concurrency utilities including a backport
+of @code{sync.Map} to Go versions below 1.9 and a cancellable Goroutine with
+explicit ownership.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-mreiferson-go-options
   (package
     (name "go-github-com-mreiferson-go-options")