summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-20 10:10:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:41 +0100
commit0540c0ccb275c2a01bf7d9084a65a775d7863ae0 (patch)
tree7b795a37239fc5cc07b0c2efae60304e00808e16 /gnu/packages
parentfc9eb91b0cbf2130282433797235f175c2a19992 (diff)
downloadguix-0540c0ccb275c2a01bf7d9084a65a775d7863ae0.tar.gz
gnu: go-golang-org-x-sys: Fix indentation.
* gnu/packages/golang-build.scm (go-golang-org-x-sys): Re indent.

Change-Id: I63f95e9fb8d6d633fbb0642100c60d5df9121730
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-build.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index e744d16e5a..9bc9802d19 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -307,37 +307,37 @@ cancelation for groups of goroutines working on subtasks of a common task
     (license license:bsd-3)))
 
 (define-public go-golang-org-x-sys
-    (package
-      (name "go-golang-org-x-sys")
-      (version "0.21.0")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://go.googlesource.com/sys")
-               (commit (string-append "v" version))))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "000fcyi863sbmamdn3cwfv3s3z9ls5l34xnjavcbgjs591ghki8y"))))
-      (build-system go-build-system)
-      (arguments
-       (list
-        #:import-path "golang.org/x/sys"
-        #:phases
-        #~(modify-phases %standard-phases
-            ;; XXX: Workaround for go-build-system's lack of Go modules
-            ;; support.
-            (delete 'build)
-            (replace 'check
-              (lambda* (#:key tests? import-path #:allow-other-keys)
-                (when tests?
-                  (with-directory-excursion (string-append "src/" import-path)
-                    (invoke "go" "test" "-v" "./..."))))))))
-      (home-page "https://go.googlesource.com/sys")
-      (synopsis "Go support for low-level system interaction")
-      (description "This package provides supplemental libraries offering Go
+  (package
+    (name "go-golang-org-x-sys")
+    (version "0.21.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://go.googlesource.com/sys")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "000fcyi863sbmamdn3cwfv3s3z9ls5l34xnjavcbgjs591ghki8y"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "golang.org/x/sys"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Workaround for go-build-system's lack of Go modules
+          ;; support.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
+    (home-page "https://go.googlesource.com/sys")
+    (synopsis "Go support for low-level system interaction")
+    (description "This package provides supplemental libraries offering Go
 support for low-level interaction with the operating system.")
-      (license license:bsd-3)))
+    (license license:bsd-3)))
 
 (define-public go-golang-org-x-term
   (package