summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-09-17 23:12:01 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-18 11:11:26 +0200
commit065b135ee14668d1cbe679a91d877e60f25cf3dc (patch)
treefadbad7eebe5158e6bc9252802e6bd4c38c8231d /gnu/packages
parent1225fe013e2f5e91a7a05be745e5cbf8ae507b02 (diff)
downloadguix-065b135ee14668d1cbe679a91d877e60f25cf3dc.tar.gz
gnu: Add emacs-suneater-theme.
* gnu/packages/emacs-xyz.scm (emacs-suneater-theme): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 17740756b5..0d1843df95 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1348,6 +1348,28 @@ color scheme used by Visual Studio Code.")
 Apprentice and Sourcerer.")
       (license license:gpl3+))))
 
+(define-public emacs-suneater-theme
+  (package
+    (name "emacs-suneater-theme")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~plattfot/suneater-theme")
+             (commit version)))
+       (sha256
+        (base32
+         "0nlam8f8ly86y7p2dn10y9ixnm7bhmigsx7si4cjynh6aiyczyds"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://git.sr.ht/~plattfot/suneater-theme")
+    (synopsis "Minimalistic dark theme for Emacs")
+    (description
+     "Suneater is a dark, minimalistic Emacs theme.  It was based on Sunburst
+theme but now takes more inspiration from the Nano theme.")
+    (license license:gpl3+)))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")