summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2023-08-25 14:31:23 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-14 16:13:49 +0200
commit08e8c3483fa16b4fc9b1fbd92f52bbc778f65249 (patch)
tree41d53bce85197f6482daedd9b140adcf99e6fd01 /gnu/packages
parente645a53d87be1132bb7f8c3c0afc5967e061fb94 (diff)
downloadguix-08e8c3483fa16b4fc9b1fbd92f52bbc778f65249.tar.gz
gnu: syncthing: Update to 1.23.7.
The uraggregate binary was merged into ursrv, so don’t attempt to install it.

* gnu/packages/syncthing.scm (syncthing): Update to 1.23.7.
[arguments]: Build with go-1.20.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/syncthing.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 414395251b..fd30360006 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,7 +46,7 @@
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "1.23.6")
+    (version "1.23.7")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -54,7 +54,7 @@
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "03myinspq61aiis29mq0xjigj5rh5jd8m0d9xakf43vi7pqgwjbc"))))
+                "1891dqcsg5r034bw19qjm6qg0zi1g0djcllp2c550zq7v1sdvn0q"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
@@ -64,7 +64,7 @@
      (list #:modules '((srfi srfi-26) ; for cut
                        (guix build utils)
                        (guix build go-build-system))
-           #:go go-1.19
+           #:go go-1.20
            #:import-path "github.com/syncthing/syncthing"
            ;; We don't need to install the source code for end-user applications.
            #:install-source? #f
@@ -101,7 +101,7 @@
                                "stdisco" "stdiscosrv" "stevents" "stfileinfo"
                                "stfinddevice" "stfindignored" "stgenfiles"
                                "strelaypoolsrv" "strelaysrv" "stsigtool"
-                               "stvanity" "stwatchfile" "uraggregate" "ursrv")))))
+                               "stvanity" "stwatchfile" "ursrv")))))
 
          (add-after 'install 'install-docs
            (lambda _