summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:56:57 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:09 +0300
commit0acfc481a4544f738c81ddbf746afa8a7b43f124 (patch)
treefb932ee30b894130068dcb6e496f1fe5331d9bfd /gnu/packages
parent20b5b16ee975b9009e9029818b566d492b6ed766 (diff)
downloadguix-0acfc481a4544f738c81ddbf746afa8a7b43f124.tar.gz
gnu: Add emacs-tree-mode.
* gnu/packages/emacs.scm (emacs-tree-mode): New public variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d8f5ce17dd..6c44bdfef2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8426,3 +8426,27 @@ orient yourself in the code, and tell which statements are at a given level.")
     (description "This package provides an Emacs library to create, query,
 navigate and display hierarchy structures.")
     (license license:gpl3+)))
+
+(define-public emacs-tree-mode
+  (let ((commit "b06078826d5875d74b0e7b7ac47b0d0917610534")
+        (revision "1"))
+    (package
+      (name "emacs-tree-mode")
+      (version (string-append "0.0.1" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/tree-mode.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "13bbdhdmqg4x9yghanhr8fsbsxbnypzxdxgicz31sjjm675kpnix"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacsorphanage/tree-mode")
+      (synopsis "Emacs mode to manage tree widgets")
+      (description
+       "This package provides an Emacs library to manage tree widgets.")
+      (license license:gpl3+))))