summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:33:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:02 +0200
commit0dbff50cfa6007b52568a735a8121de42b4f5813 (patch)
tree7dae0e4bd608f597d828b71ef6028c24d95d6615 /gnu/packages
parent34a7fa399ea61365616b1d88fc086e598dbe27c4 (diff)
downloadguix-0dbff50cfa6007b52568a735a8121de42b4f5813.tar.gz
gnu: Add texlive-schule.
* gnu/packages/tex.scm (texlive-schule): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6be7ce8964..fbcba627a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -26799,6 +26799,32 @@ provided by one of two options to @code{newtxmath}, one of which uses an
 adaptation of the Fourier math Greek letters.")
     (license license:lppl)))
 
+(define-public texlive-schule
+  (package
+    (name "texlive-schule")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/schule/" "tex/latex/schule/")
+             (base32
+              "0pwc75s9r95rcq9xh2wjzv3hd2xqhkls39pgagg7gvdvax11dbvh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/schule")
+    (synopsis "Support for teachers at German schools")
+    (description
+     "The @code{schule} bundle was built to provide packages and commands that
+could be useful for documents in German schools.  At the moment, its main
+focus lies on documents for informatics as a school subject.  An extension for
+physics is currently in progress.
+
+For the time being, the whole package splits up into individual packages for
+informatics (including syntax diagrams, Nassi-Shneiderman diagrams, sequence
+diagrams, object diagrams, and class diagrams) as well as classes for written
+exams (tests, quizzes, teaching observations, information sheets, worksheets,
+and answer keys).")
+    (license license:lppl1.3+)))
+
 (define-public texlive-schulschriften
   (package
     (name "texlive-schulschriften")