summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2024-08-29 16:37:07 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-05 10:14:25 +0200
commit0fcd05b0444a4ae6423bd72f62b8284e49a59e13 (patch)
tree310e6acb94c846fd85f90c9efd75b1eab717beaf /gnu/packages
parent8d5d66887e825a0cbc40030b4d07b0eee92af573 (diff)
downloadguix-0fcd05b0444a4ae6423bd72f62b8284e49a59e13.tar.gz
gnu: sundials: Upgrade to 7.1.1.
* gnu/packages/maths.scm (sundials): Update to 7.1.1.
[native-inputs]: Add PKG-CONFIG.
(sundials-openmpi)[arguments]: Pass ‘-DPETSC_INCLUDE_DIRS’ instead of
‘-DPETSC_DIR’.

Change-Id: I750415109d69b53afbcf461dc98b2028af03c35a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index dffe7c4ea6..642932c0ac 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8051,7 +8051,7 @@ and comparisons are supported.")
 (define-public sundials
   (package
     (name "sundials")
-    (version "6.2.0")
+    (version "7.1.1")
     (source
      (origin
        (method url-fetch)
@@ -8059,10 +8059,10 @@ and comparisons are supported.")
                            version "/sundials-" version ".tar.gz"))
        (sha256
         (base32
-         "07gk9060xk3bzfqf8v4fqlp0rcxswiwlsy887zv87i1gfy9map8r"))))
+         "1fwlgbcdxz30dzsqw3y1b6ic1rhzfadghj7cq7yxsj14npgnwzga"))))
     (build-system cmake-build-system)
     (native-inputs
-     (list python-2))          ; For tests; syntax incompatible with Python 3.
+     (list pkg-config python-2)) ;for tests; syntax incompatible with Python 3
     (inputs
      (list openblas suitesparse))
     (arguments
@@ -8115,8 +8115,9 @@ easily be incorporated into existing simulation codes.")
                                (assoc-ref %build-inputs "hypre-openmpi")
                                "/lib")
                 "-DENABLE_PETSC:BOOL=ON"
-                (string-append "-DPETSC_DIR="
-                               (assoc-ref %build-inputs "petsc-openmpi"))
+                (string-append "-DPETSC_INCLUDE_DIRS="
+                               (assoc-ref %build-inputs "petsc-openmpi")
+                               "/include")
                 ,flags))
        ((#:phases phases '%standard-phases)
         `(modify-phases ,phases