summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 13:59:52 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:45 +0200
commit1004c54c2e0786ceb210405de96f1106e043ba76 (patch)
tree70ae4a0a8d6ae81f9c38ba7c832d77303376d08a /gnu/packages
parentced05db048ca60afe227acdcad9c794f231bf16d (diff)
downloadguix-1004c54c2e0786ceb210405de96f1106e043ba76.tar.gz
gnu: sbcl-trivial-clipboard: Replace xclip with xsel to reduce closure size.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-clipboard)[inputs]: Replace xclip
with xsel.
[arguments]: Adapt reference.

This takes the closure size of cl-trivial-clipboard from 90 MiB down to 78 MiB.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1a8491a00f..90c89419b9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3853,7 +3853,9 @@ client and server.")
            "0apkgqrscylw3hhm5x2vs0z3hz6h7zd7dl5y3wr2zl8qjpvpc80k"))))
       (build-system asdf-build-system/sbcl)
       (inputs
-       (list xclip))
+       ;; Pick xsel instead of xclip because its closure size is slightly
+       ;; smaller.
+       (list xsel))
       (native-inputs
        (list sbcl-fiveam))
       (arguments
@@ -3862,8 +3864,8 @@ client and server.")
            (add-after 'unpack 'fix-paths
              (lambda* (#:key inputs #:allow-other-keys)
                (substitute* "src/text.lisp"
-                 (("\"xclip\"")
-                  (string-append "\"" (assoc-ref inputs "xclip") "/bin/xclip\""))))))))
+                 (("\"xsel\"")
+                  (string-append "\"" (assoc-ref inputs "xsel") "/bin/xsel\""))))))))
       (home-page "https://github.com/snmsts/trivial-clipboard")
       (synopsis "Access system clipboard in Common Lisp")
       (description