summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-10 22:29:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:36:53 +0100
commit11313556c59f01455533ec5f38b5a5317fe5863c (patch)
tree525a5fc416ee2de59e21509966dc194cded914eb /gnu/packages
parent89e844d82586a56218ec65c3cc945e4a80093c7c (diff)
downloadguix-11313556c59f01455533ec5f38b5a5317fe5863c.tar.gz
gnu: Remove go-etcd-io-bbolt.
go-go-etcd-io-bbolt and go-etcd-io-bbolt are the same version and source
packages. This change removes go-etcd-io-bbolt and keeps
go-go-etcd-io-bbolt.

* gnu/packages/configuration-management.scm (chezmoi) [native-inputs]:
Add go-go-etcd-io-bbolt. Remove go-etcd-io-bbolt.
* gnu/packages/golang.scm (go-etcd-io-bbolt): Remove variable.

Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I482f22b77b61d4761390742db2ced570cd4de3bd
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/configuration-management.scm4
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 2 insertions, 25 deletions
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 89958b351e..818a80b94e 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -82,8 +82,7 @@
                           "secretonepassword.txt"
                           "secretpass.txt")))))))
     (native-inputs
-     (list go-etcd-io-bbolt
-           go-github-com-alecthomas-chroma
+     (list go-github-com-alecthomas-chroma
            go-github-com-aymerick-douceur
            go-github-com-bmatcuk-doublestar-v2
            go-github-com-charmbracelet-glamour
@@ -121,6 +120,7 @@
            go-github-com-yuin-goldmark
            go-github-com-zalando-go-keyring
            go-github-go-git
+           go-go-etcd-io-bbolt
            go-golang-org-x-net
            go-golang-org-x-oauth2
            go-golang-org-x-term
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d3132ad1d2..1c457b9395 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7703,29 +7703,6 @@ losing type information.  The primary intended use is for implementing
 configuration languages, but other uses may be possible too.")
     (license license:expat)))
 
-(define-public go-etcd-io-bbolt
-  (package
-    (name "go-etcd-io-bbolt")
-    (version "1.3.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/etcd-io/bbolt")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "go.etcd.io/bbolt"))
-    (propagated-inputs
-     (list go-golang-org-x-sys))
-    (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
-    (synopsis "Low-level key/value store in Go")
-    (description "This package implements a low-level key/value store in Go.")
-    (license license:expat)))
-
 (define-public go-github-com-rogpeppe-go-internal
   (package
     (name "go-github-com-rogpeppe-go-internal")