summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-10-18 11:38:00 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:14:52 +0100
commit152b636f88d4867c8c3e62cdb37ece6a1375dc80 (patch)
tree8f21131487c71e560f204ae410539b0f67c50bfd /gnu/packages
parent4d1079b9c91f470ad0046cf72428728c75d8a52a (diff)
downloadguix-152b636f88d4867c8c3e62cdb37ece6a1375dc80.tar.gz
gnu: Add go-github-com-lestrrat-go-strftime.
* gnu/packages/golang-xyz.scm (go-github-com-lestrrat-go-strftime): New
variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I8f4fcc42608357c409dc38e63c1b2b1d3083b268
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 649bd76a72..e469c0007d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1685,6 +1685,42 @@ or during the tests temporarily change the value of an environment variable in
 Golang.")
     (license license:expat)))
 
+(define-public go-github-com-lestrrat-go-strftime
+  (package
+    (name "go-github-com-lestrrat-go-strftime")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lestrrat-go/strftime")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1iqzxmj3ijldjf99acy44qrrzvfxzn0vza3m0c9bw46bg8v1wsyc"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/lestrrat-go/strftime"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-benchmarks
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively
+                        (string-append "src/" import-path "/bench")))))))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (propagated-inputs
+     (list go-github-com-pkg-errors
+           go-github-com-lestrrat-go-envload))
+    (home-page "https://github.com/lestrrat-go/strftime")
+    (synopsis "Strftime for Golang")
+    (description
+     "This package provides a Golang library implementing the conversion of
+date and time information from a given calendar time to a character string
+according to a format string.  It is optimized for scenarios where the same
+pattern is called repeatedly.")
+    (license license:expat)))
+
 (define-public go-github-com-lib-pq
   (package
     (name "go-github-com-lib-pq")