summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-20 18:57:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-20 18:57:39 +0200
commit171bcdf7ba1425072529bacb712792b2a6302544 (patch)
treef532bcab98feb5580a572456e65ce78db2b9548b /gnu/packages
parent164fccea7eead86c6ebe389bc0255c72b161d109 (diff)
downloadguix-171bcdf7ba1425072529bacb712792b2a6302544.tar.gz
gnu: gdk-pixbuf: Remove graft for 2.36.10.
* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.36.10.
[replacement]: Remove field.
(gdk-pixbuf+svg)[replacement]: Likewise.
(gdk-pixbuf-2.36.10, gdk-pixbuf+svg-2.36.10): Remove variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0d3da63ca6..dd7739d5e7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -427,8 +427,7 @@ highlighting and other features typical of a source code editor.")
 (define-public gdk-pixbuf
   (package
    (name "gdk-pixbuf")
-   (version "2.36.9")
-   (replacement gdk-pixbuf-2.36.10)
+   (version "2.36.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/" name "/"
@@ -436,7 +435,7 @@ highlighting and other features typical of a source code editor.")
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
-              "02klisz3ly0bvflj39x49lnl4mnldsgvkjdvnla1as8szxqv44w0"))))
+              "1klsjkdbashd8yb8xjsc9ff3bz32n2id5s79nrrmqiw9df4zmxpq"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags '("--with-x11")
@@ -483,7 +482,6 @@ in the GNOME project.")
 (define-public gdk-pixbuf+svg
   (package (inherit gdk-pixbuf)
     (name "gdk-pixbuf+svg")
-    (replacement gdk-pixbuf+svg-2.36.10)
     (inputs
      `(("librsvg" ,librsvg)
        ,@(package-inputs gdk-pixbuf)))
@@ -507,26 +505,6 @@ in the GNOME project.")
     (synopsis
      "GNOME image loading and manipulation library, with SVG support")))
 
-;; Graft replacement packages to fix these vulnerabilities.
-;; https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2862
-;; https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2870
-;; https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6311
-(define-public gdk-pixbuf-2.36.10
-  (package (inherit gdk-pixbuf)
-           (version "2.36.A")
-           (source (origin
-                     (method url-fetch)
-                     (uri (string-append "mirror://gnome/sources/gdk-pixbuf/2.36/"
-                                         "gdk-pixbuf-2.36.10.tar.xz"))
-                     (sha256
-                      (base32
-                       "1klsjkdbashd8yb8xjsc9ff3bz32n2id5s79nrrmqiw9df4zmxpq"))))))
-
-(define-public gdk-pixbuf+svg-2.36.10
-  (package (inherit gdk-pixbuf+svg)
-           (version "2.36.A")
-           (source (origin (inherit (package-source gdk-pixbuf-2.36.10))))))
-
 (define-public at-spi2-core
   (package
    (name "at-spi2-core")