summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-12 23:32:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:42 +0000
commit179bd842d3652c21be9b8b1815bcc208bb732154 (patch)
treeb837102f4a4f37ed1bf27fce5c133ea52a93ab3a /gnu/packages
parentf75620892bb56e7d9fff46dad516b0bb3d12b561 (diff)
downloadguix-179bd842d3652c21be9b8b1815bcc208bb732154.tar.gz
gnu: Add go-golang-org-x-telemetry-config.
* gnu/packages/golang-build.scm (go-golang-org-x-telemetry-config): New variable.

Change-Id: I3958fa220149360ef4008b2c93301a41d5f6e063
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-build.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index aa113dd16b..f81da8205c 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -667,6 +667,36 @@ for hosting @url{https://telemetry.go.dev,telemetry.go.dev} and instrumenting
 Go toolchain programs with opt-in telemetry.")
     (license license:bsd-3)))
 
+(define-public go-golang-org-x-telemetry-config
+  (package
+    (name "go-golang-org-x-telemetry-config")
+    (version "0.31.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://go.googlesource.com/telemetry")
+             (commit (go-version->git-ref version
+                                          #:subdir "config"))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b5f3kf58wam741m7vfalv4n47djn6whxr4lf9w1jpjgaa6kq3an"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "golang.org/x/telemetry/config"
+      #:unpack-path "golang.org/x/telemetry"))
+    (home-page "https://golang.org/x/telemetry")
+    (synopsis "Subset of telemetry data for Golang telemetry")
+    (description
+     "The config package holds the config.json file defining the Go telemetry
+upload configuration and contains no actual Go code, and exists only so the
+config.json file can be served by module proxies.
+
+An upload configuration specifies the set of values that are permitted in
+telemetry uploads: GOOS, GOARCH, Go version, and per-program counters.")
+    (license license:bsd-3)))
+
 (define-public go-golang-org-x-term
   (package
     (name "go-golang-org-x-term")