summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:59:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:37 +0100
commit3244c6ca88d7416641248456fb8cecafeec3f9b1 (patch)
tree5d71c79e53966723021c447bd9a3685d324afa2f /gnu/packages
parentf0e5d0b411f1465e11058eb40eac467e75bd8d81 (diff)
downloadguix-3244c6ca88d7416641248456fb8cecafeec3f9b1.tar.gz
gnu: go-github-com-go-ldap-ldap: Update to 3.4.8.
* gnu/packages/golang-web.scm (go-github-com-go-ldap-ldap): Update to 3.4.8.
[propagated-inputs]: Add go-github-com-google-uuid.

Change-Id: Ic8792cbe8b911c23fdcb87612928b86bd89dc95a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 13074eb851..421468a6b8 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -792,7 +792,7 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
 (define-public go-github-com-go-ldap-ldap
   (package
     (name "go-github-com-go-ldap-ldap")
-    (version "3.4.1")
+    (version "3.4.8")
     (source
      (origin
        (method git-fetch)
@@ -801,15 +801,16 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1xf2jrwhgr06jy4liba48hrz4b7j27r7m9dnl7fj95vazsx2n5br"))))
+        (base32 "0fbmhlc8ss5vn6zz0iiifvy4pm0mwaf13qpz70k83mmnv9vrv16x"))))
     (build-system go-build-system)
     (arguments
      (list
       #:tests? #f ; test suite requires internet access
       #:import-path "github.com/go-ldap/ldap/v3"))
     (propagated-inputs
-     (list go-github-com-go-asn1-ber-asn1-ber
-           go-github-com-azure-go-ntlmssp))
+     (list go-github-com-azure-go-ntlmssp
+           go-github-com-go-asn1-ber-asn1-ber
+           go-github-com-google-uuid))
     (home-page "https://github.com/go-ldap/ldap")
     (synopsis "LDAP v3 functionality for Go")
     (description "This package provides basic LDAP v3 functionality in the Go