summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 21:15:06 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:50 +0000
commit32a46662432a0df523afb89cab515e4bb027c31c (patch)
treea485ba5ba4009de4a817a025f47db429b1805dcc /gnu/packages
parent7c49f2f0aa875abdbbac16800ce9df03c21f8fb0 (diff)
downloadguix-32a46662432a0df523afb89cab515e4bb027c31c.tar.gz
gnu: Add go-msgp.
* gnu/packages/golang-xyz.scm (go-msgp): New variable.

Change-Id: Ia9b339e6ea413c6d3442ecdcda56e6ce0be5c87b
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 50b3d468ce..f1bb7b3259 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8184,6 +8184,20 @@ correctly.")))
       #:unpack-path "github.com/libp2p/go-msgio"))
     (synopsis "CLI tool to wrap messages with msgio header.")))
 
+(define-public go-msgp
+  (package
+    (inherit go-github-com-tinylib-msgp)
+    (name "go-msgp")
+    (arguments
+     (list
+      #:install-source? #f
+      #:tests? #f
+      #:import-path "github.com/tinylib/msgp"))
+    (description
+     (string-append (package-description go-github-com-tinylib-msgp)
+                    " This package provides an command line interface (CLI)
+tool."))))
+
 (define-public go-numcpus
   (package
     (inherit go-github-com-tklauser-numcpus)