summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-23 11:54:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-23 16:04:42 +0200
commit367bc2d198f57bc34522441820f761b61fed0ce0 (patch)
tree4b1b5c3e916b3b2634f6e31f1b0bfe084c2968ea /gnu/packages
parentfbeae77ae6b8c4ad1c23e65d172b38c5a80bf2e3 (diff)
downloadguix-367bc2d198f57bc34522441820f761b61fed0ce0.tar.gz
gnu: source-highlight: Wrap scripts.
* gnu/packages/pretty-print.scm (source-highlight)[arguments]: Add a
phase to wrap shell scripts so they can find the source-hightlight
binary.
[inputs]: Add guile-3.0.

Change-Id: Ia8d006d969385210d5c82b4a0dd1f78178306ac2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/pretty-print.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 34d413f8c9..8afe73da45 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019, 2020, 2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -47,6 +47,7 @@
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages guile)
   #:use-module (gnu packages gv)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages lua)
@@ -304,7 +305,7 @@ a fast alternative to @code{IOStreams}.")
     ;; The ctags that comes with emacs does not support the --excmd options,
     ;; so can't be used
     (inputs
-     (list boost))
+     (list boost guile-3.0))
     (native-inputs
      (list bison flex))
     (arguments
@@ -336,7 +337,15 @@ a fast alternative to @code{IOStreams}.")
                    (substitute* '("tests/test.sh.html"
                                   "tests/test2.sh.html"
                                   "tests/test.tcl.html")
-                     (("#! */bin/sh") "#!/bin/sh")))))))
+                     (("#! */bin/sh") "#!/bin/sh"))))
+               (add-after 'install 'wrap-scripts
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (for-each
+                     (lambda (script)
+                       (wrap-script (string-append #$output "/bin/" script)
+                         `("PATH" ":" prefix (,(string-append #$output "/bin")))))
+                     (list "cpp2html" "java2html" "source-highlight-esc.sh"
+                           "src-hilite-lesspipe.sh")))))))
     (home-page "https://www.gnu.org/software/src-highlite/")
     (synopsis "Produce a document with syntax highlighting from a source file")
     (description