summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-06 00:07:50 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-09 22:10:11 -0500
commit39bd088e75c71ae90430f41cdec187b7734d2bf4 (patch)
treec9b86304ed7fabb26d41675f77ef93984918a6c0 /gnu/packages
parent0ec349078f49a1ef621b709fe08c7fd21aee5755 (diff)
downloadguix-39bd088e75c71ae90430f41cdec187b7734d2bf4.tar.gz
gnu: Add llhttp.
* gnu/packages/web.scm (llhttp): New variable.

Change-Id: I3c0475ff6d86a16f51d8870577808ce97ee66a92
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 13ae53aa8c..41295a1e90 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -46,7 +46,7 @@
 ;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
@@ -6621,6 +6621,28 @@ Depending on your architecture, it only requires about 40 bytes of data per
 message stream (in a web server that is per connection).")
       (license license:expat))))
 
+(define-public llhttp
+  (package
+    (name "llhttp")
+    (version "9.1.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nodejs/llhttp")
+                    (commit (string-append "release/v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nkv64c5fs8x6n5f9f6g28w5hvg776p55cwa0f82ni548nx279s1"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f))      ;FIXME: tests depend on node-mocha
+    (home-page "https://github.com/nodejs/llhttp")
+    (synopsis "Port of http_parser to llparse")
+    (description "@code{llparse} is a port of @code{http_parser} to
+@code{llparse} which aims making it more maintainable, verifiable and
+efficient where possible.")
+    (license license:expat)))
+
 (define-public python-httpretty
   (package
     (name "python-httpretty")